Getting Started with Altera Quartus 11

NOTE: Step 1 and Step 2 are to be followed only if you are installing Altera Quartus Il for the first
time. If you are using EECS commons or lab computers, you can start with Step 3 as the software is
pre-installed.

Step 1: Install the Altera Quartus 7.1 CD that comes with your book

1.) The Quartus Il CAD software can be installed by running the following command in the command
prompt: Start->Programs->Accesories->Command

<CD-ROM drive>\CDROM\Quartus_I1\72sp2_quartus_free.exe
(For my computer the CD-ROM drive was H:)

2.) The installation process involves a series of steps.Choosing a complete install will require
approximately 1.5 GB of free space.Make sure you have enough space on your target directory.

Step 2: Obtaining the license file

1.) After the installation you need a license file which has to be downloaded.
2.) Open your browser and go to www.altera.com/licensing
3.) Click on the Get licenses link which is the first blue link on the page

4.) Click on Get a license for Quartus® Il Web Edition software and the ModelSim®-Altera Web
Edition software that is also the first link on the page

5.) You should create an account using your e-mail address. Alternatively, you can use the Get one
time access option. You will be asked to enter information about you in this process.

6.) Once you have an username and password you can go back to Step 2.5 and now enter the username
and password.

7.) As part of the procedure you will be asked to provide your network interface card number.

The Network Interface Card (NIC) number is a 12-digit hexadecimal number that identifies your
computer. You can find the NIC number for your network card by typing ipconfig /all ata
command prompt. Your NIC number is the number on the physical address line, minus the dashes, for
example, @OCO4FA392EF

So, to obtain this number, type the following command in a Windows Command Prompt window:
ipconfig /all



Look for the line of the form
Physical Address. . . . . . . . . : 00-CO-4F-A3-92-EF

The last part of this line is the network interface card number. In this example, you would type
@OCOAFA392EF (without the - dashes) into the box that says "Enter your network interface card
(NIC) number:" on the licensing web page.

Once you have provided to Altera the required information to obtain your license file, the file will be
emailed to you along with instructions on using the license file. The email is normally returned to you
from Altera in less than one hour.

(Reference: README file of the Altera Quartus 7.1 CD)

8.) The instructions to download and specify the license file to Altera will be given to you in your e-
mail which has the license file

Step:3 Creating a New Project

Let us design, compile and simulate a simple three input AND gate:

1.) After obtaining the license you can start working on Quartus by creating a project. Go to File-
>Create New Project wizard

2.) Inthe window that pops up you have to enter the directory where you want to store your project
files, the file name and a project name and click Next. (Note: The file name should be the same as
your top-level entity). This is shown in Fig. 1



New Project Wizard: Directory, Name, Top-Level Entity [page 1 of 5] @

What is the working directory for this project?
|E:\.6.Itera\quartus\M y Altera Work Mirst_vhdl_andgate |

What is the name of this project?

|andgate| _‘

What is the name of the top-level design entity for this project? This name is case sensitive and must
exactly match the entity name in the desian file.

|andgate _l

IJse Existing Project Settings ...

I MNext > | Finish | Cancel

Fig. 1. New Project Wizard

3.) Inthis step you will be asked to enter the family and device settings. You need not worry about
this step if you are not downloading your design to a board. Click Next.

4.) Next is the EDA Tools Settings. You need not worry about this step if your project does not depend
upon files from other projects. Click Finish. The final screen should be something like Fig.2. It might
look somewhat different for you but you can ignore the device assignment settings. Just make sure that
your project directory and file name are the same as you had entered. Click Finish once you are done.



New Project Wizard: Summary [page 5 of 5] @

When you click Finish, the project will be created with the following settings:

Project directory:
E:/Altera/quartus/My Altera Work Hfirst_vhdl_andaate/

Project name: andgate
Top-level design entity: andgate
Number of files added: 0

Mumber of user libraries added: 0

Device assignments:

Family name: FLEX10K

Device: EPF10K70RC240-4
EDA tools:

Design entry/synthesis: <None>»

Simulation: <None>

Timing analysis: <None>»

< Back ey I Finish I Cancel

Fig 2. Summary of the New Project Wizard

5.) After creating a new project you can create the VHDL design file from File->New-> VHDL file.
This is shown in Fig. 3



New @

Device Design Files I Other Files I

AHDL File

Block Diagram/Schematic File
EDIF File

SOPC Builder System
Veriloi HDL File

0K Cancel

Fig.3 New VHDL file

6.) Save the file into the directory which you specified while creating your project from File->Saves

As with a .vhd extension Note: By default it will save to your project directory with . vhd extension;
you just have to make sure it does. The screen should like the one shown in Fig.4.
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Fig.4 Save the VHDL file

7.) Now you can start entering your VHDL design. Refer the VHDL tutorial for the design entry.
Once you complete your design you can save it from (File->Save) or Ctrl+s is the shortcut. The AND
gate design entry is shown in Fig.5. Note that the entity name is the same as the file name.



&, Quartus Il - E:/Altera/quartus/My Altera Work/first_vhdl_andgate/andgate - andgate - [andgate.vhd]

3@3 File Edit VYiew Project Assignments Processing Tools Window Help

(== = @B © o |andgate @RS LA M R M AR SRR ORI R
Project Navigator - x a@c dgate.vhd l
Entity I
FLEX10K: EPF10K70R... 1 LIBRARY IEEE;
2 USE IEEE.STD LOGIC 1164.ALL:
------- # andgate o - -
@& 4] 3
4 Eentity andgate is
5 = port ( x1,x2,x3 : IN 3TD_LOGIC:
iE iE 6 f ¢ OUT 5TD_LOGIC);
- 7 end andgate;
A % 8
x/v‘ % 9 Elirchitecture behavior of andgate is
10 HEbegin
0 < 11 f <= x1 AND x2 AND x3;
1z end behavior:
2
A
1 | =
& Hierarchy | B Files | 8? Desian Units | —
Status - X -
Module | Progress Z [ Time & |
<

Fig. 5. AND gate design entry

8.) There are pre-defined templates which can be obtained from Insert->Templates->VHDL for
templates. These templates can help you with the design process.

Step 4 Compiling your design

1.) Once you have completed your design you should compile it to check for errors.

2.) You can compile it using Processing->Start->Start Analysis and Synthesis or Ctrl+k is the
shortcut for that. This is shown in Fig 6.
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3.) This gives a compilation report. If you get an error you can get more information about the error by
selecting the error and pressing F1.This can help you with your debugging process. This is shown in

Fig.7

’.7‘ Start Analysis & Synthesis Chrl+K

75; Start Partition Merge
O Start Fitter
E" Start Assembler

P& Start Classic Timing Analyzer Ctrl+Shift+L
'ﬁ} Start TimeQuest Timing Analyzer  Ctrl+Shift+T
*& Start EDA Netlist Writer

zﬁ Start Design Assistant

W Start PowerPlay Power Analyzer  Ctrl+Shift+P
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Fig.6. Compiling your design
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Step 5: Simulation

Fig.7 Compilation Report

1.) Once you successfully compile your design you can simulate the waveforms.

2.) Click on File->New->Other Files->Vector Waveform Files to get a waveform editor window as

shown in Fig.8.



New @

Device Design Files  Other Files I

AHDL Include File

Block Symbol File

Chain Description File
Hexadecimal (Intel-Format) File
In-System Sources and Probes Editor File
Logic Analyzer Interface File
Memory Initialization File
SignalTap Il Logic Analyzer File
Synopsys Design Constraints File
Tcl Script File

Text File

Vector Waveform File

oK Cancel

Fig.8 Waveform Editor

You should save it in the same directory with a . vwf extension. Note: By default it will save to your
project directory with . vhd extension; you just have to make sure it does.

3.) You can specify the end time for the simulated waveform by specifying Edit->End time. This is
shown in Fig. 9.



Time: |10} lus |

Default extension options:

Extension value: ILast clock pattemn L]

End time extension per signal:

SignalName | Direction | R adix | Estension value |

Fig 9. Specify End Time
4.) Select View->Fit in Window, to show entire output for the simulated waveform.

5.) Enter the Input and Output Nodes of the circuit from Edit->Insert Node or Bus. Click on Node
Finder from the menu. You should get a window as shown in Fig. 10.



Named:[i L] Filter: IPins: all L] Customize... List | L% I

Look in: l __JJ IV Include subentities I Cancel I
Nodes Found: Selected Nodes:
Name l Assighments ] T Name l Assighments ] T

ERIRE

Fig 10. Node Finder Window

6.) In the resulting window select all for Pins from the drop down menu and click on list.

7.) Now all the pins of your design will be listed on the left pane. Select each pin and click on > to
move the pin to the right pane. You should repeat this for each pin. Click OK.

8.) Now you should be able to get all the pins in your waveform editor window. The screen should
look like the one in Fig. 11.
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Fig 11. Node Finder

9.) The time period for each waveform (x1, x2 and x3) can be entered by clicking on the Overwrite
Clock icon from the vertical tool bar in the waveform editor window. This is shown in Fig. 12 and Fig.
13. Let us use a time period of 1, 0.5 and 0.25 microseconds for x1, x2, x3 respectively for this
example. Save the input in your project directory with a . vwf extension. After entering the screen
should like the one shown in Fig 14. Note the output pin f has does not have a waveform. We will see
the output waveform after we simulate.



4, Quartus Il - E:/Altera/quartus/My Altera Work/first_vhdl_andgate/andgate - andgate - [Waveform1.vwf*]

'@File Edit View Project Assignments Processing Tools Window Help

DEelE & & B « o Iandgate

X s @RS T > W GH N S8 Qe

Project Navigator - x a@: e I @ Compilation Report - Flow Summary I '@ Waveform1.vwf*
Entity | Logic [
Ay FLEX10K: EPF10K70RC240-4 |§| Master Time Bar: 15,675 ns «| »| Painter: 200.25 ns Interval: 184.58 ns Start: Ops End:
1 A ps 6400ns 128us 192us 25Bus 32us 384us 44Bus 612us 576us  G4us 704us 76Bus
[N Name | Yalueat e ; ; b G h i h i i v i
.675 ns
w5 Q 1568 ns ‘
o 29 ax
an 1 1 AD
LR o) A0
)@ X 3 %3 AD
o 1
ir i
4
—
e
<3 ] ]
-®Hielavchy [B Files | &P Design Units )@ )@
2 YR
Status R X: {overwrite Clock]
Module | Progress 7 [ Time & | 8% 4
Analysis & Synthesis 00:00:05

Fig 12. Overwrite Clock to enter time period.

Time range
Start time: |D | ps LI
Endtime: |10.0 lus |

Base waveform on
o

;._I

' Time period:

Period: |1 I ':l
Offset |00 s+
Duty cycle [%): (50 =

| 0K I Cancel |

Fig 13. Enter Time Period
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Fig 14. Waveforms

10.) There are two types of Simulator modes: Functional and timing. The difference between them is
that functional mode does not show prorogation delays. This can be selected from Assignment-
>Settings->Simulator and choosing Simulator mode. Let us do a functional simulation to start with.
The screen should look like Fig 15. Enter the simulation input file by browsing to your project folder.

The screen should look like Fig 16.



Settings - andgate

Category:

[ [ [ 4 4]

General
Files
Libraries
Device
Operating Settings and Conditions
Compilation Process Settings
EDA Tool Settings
Analysis & Synthesis Settings
Fitter Settings
Timing Analysis Settings
Assembler
Design Assistant
SignalT ap Il Logic Analyzer
Logic Analyzer Interface
Simulator Settings
Simulation Verification
Simulation Output Files
PawerPlay Power Analyzer Settings

Select simulation options.

Simulation mode: |Timing LI

S %&Eﬂ—
Timing using Fast Timing Model

Simulation period

" Run simulation until all vector stimuli are used

" End simulation at: l I“f Ll

Glitch filtering options: |,“u',w_m:u ;l

More Settings... |

Description:

Specifies the type of simulation to perform for the current Simulation focus.

Fig.15 Functional Simulation Settings




Settings - andgate @

Category:
General Simulator Settings
Files
Libraries Select simulation options.
Device
[+ Dperating Settings and Conditions . . ) -
[+ Compilation Process Settings SR |Funct|ona| LI
# EDA Tool Settings Simulation input [andgate. vt |Z| Add Multiple Files. . |
[+ Analysis & Synthesis Settings
[+ Fitter Settings i~ Simulation period
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Assembler } ;
Design Assistant " End simulation at I l ! LI
SignalTap Il Logic Analyzer 5
Logic Analyzer Interface Glitch filtering options: | .1 =]

=1 Simulator Settings

Simulation Verification More Settings... |

Simulation Output Files
PowerPlay Power Analyzer Settings

Description:
Specifies the end time for simulation.

Fig. 16 Functional Simulation Settings

11.) Save the changes made till now. If you choose functional mode go to Processing->Generate
Functional Simulation Netlist. Click OK on the dialog box that appears.

12.) The simulation can be started from Processing->Start Simulation or shortcut (Ctrl+i). The final
output should be like the one shown on Fig.17

The shortcut to compile and simulate is Ctrl+Shift+k.



4, Quartus Il - E:/Altera/quartus/My Altera Work/first_vhd|_andgate/andgate - andgate - [Simulation Report - Simulation Waveforms]

@File Edit VYiew Project Assignments Processing Tools Window Help

DS | & 2| 9 o |[andgate R - e XX Rl AL K R SRR )
ijéa Do) . x a@: andgate.vhd l @ Compilation Report - Flow Summary ] ﬁ andgate. vwf I @ Simulation Report - Simula
T lLogo | g Soiaton Repot
& LEXT0K: EPF10K70RC240-4 EB Legal Notice Simulation mode: Functional
i b andgate 1m & Flow Summary
EHER Flow Settings
=1 &3 simulator
SHER summary
SHER Settings k Master Time Bar: 15.675 ns «| »| Painter: £623.99 ns Interval: 608.32 ns Start: End:
5‘@ Simulation Waveforms
+- & Simulation Coverage A Value at ps 6400 ns 1.28us 1.92us 256 us 32us 3.84us ¢
SHEE INI Usage o Name | ygea e |[15675ns
& 5> Messages @ i
@0 f A0 1 M 1 1
[ il 40 ] ] I | J | J |
2 %2 A0
A 3 3 A0
<)) i) ¥ ]
_&Hieralchy [B Files | & Design Urits N
Status X g9
Module | Progress 7 | Time ® | 8l
Simulator 00:00:01 z
<
£ I Type Il{essage

Fig 17. Simulated Waveform

This ends the tutorial. You can try implementing other designs.



